股票视频教程网

通达信狄马克拐点主图指标公式

Class:通达信公式 Time:2020-10-26 Hits:356

通达信狄马克拐点主图指标公式
TD准备:=IF(REF(C,1)>REF(C,4),1,0);
TD0:=BARSLAST(TD准备);
A:=IF(BARSSINCEN(LAST(C<REF(C,4),9,0),9),1,DRAWNULL);
F:=IF(BARSLASTCOUNT(C<REF(C,4))>=9,1, A);
G:=A+F;

TD11:=IF(1,TD0=1,0);
{TD21:=IF(1,LLV(C,1)<REF(C,4),0);}
TD21:=IF(1,G,DRAWNULL);
A1:=TD11 AND TD21;

TD12:=IF(2,TD0=2,0);
{TD22:=IF(2,LLV(C,2)<REF(C,4),0);}
TD22:=IF(2,G,DRAWNULL);
A2:=TD12 AND TD22;
TD13:=IF(3,TD0=3,0);
{TD23:=IF(3,LLV(C,3)<REF(C,4),0);}
TD23:=IF(3,G,DRAWNULL);
A3:=TD13 AND TD23;
TD14:=IF(4,TD0=4,0);
{TD24:=IF(4,LLV(C,4)<REF(C,4),0);}
TD24:=IF(4,G,DRAWNULL);
A4:=TD14 AND TD24;
TD15:=IF(5,TD0=5,0);
{TD25:=IF(5,LLV(C,5)<REF(C,4),0);}
TD25:=IF(5,G,DRAWNULL);
A5:=TD15 AND TD25;
TD16:=IF(6,TD0=6,0);
{TD26:=IF(6,LLV(C,6)<REF(C,4),0);}
TD26:=IF(6,G,DRAWNULL);
A6:=TD16 AND TD26;
TD17:=IF(7,TD0=7,0);
{TD27:=IF(7,LLV(C,7)<REF(C,4),0);}
TD27:=IF(7,G,DRAWNULL);
A7:=TD17 AND TD27;
TD18:=IF(8,TD0=8,0);
{TD28:=IF(8,LLV(C,8)<REF(C,4),0);}
TD28:=IF(8,G,DRAWNULL);
A8:=TD18 AND TD28;
TD19:=IF(9,TD0=9,0);
{TD29:=IF(9,LLV(C,9)<REF(C,4),0);}
TD29:=IF(9,G,DRAWNULL);
A9:=TD19 AND TD29;
DRAWTEXT(A1,L-0.3,'1'),COLORYELLOW;
DRAWTEXT(A2,L-0.3,'2'),COLORYELLOW;
DRAWTEXT(A3,L-0.3,'3'),COLORYELLOW;
DRAWTEXT(A4,L-0.3,'4'),COLORYELLOW;
DRAWTEXT(A5,L-0.3,'5'),COLORYELLOW;
DRAWTEXT(A6,L-0.3,'6'),COLORYELLOW;
DRAWTEXT(A7,L-0.3,'7'),COLORYELLOW;
DRAWTEXT(A8,L-0.3,'8'),COLORYELLOW;
DRAWTEXT(A9,L-0.3,'9'),COLORYELLOW;

{TD13次倒数=买入计数}
TDP:=BARSLAST(A9);
B:=IF(LAST(C<REF(C,2),13,0),1,DRAWNULL);
TD11A:=IF(1,TDP=1,TDP);
TD21A:=IF(1,LLV(C,1)<REF(L,2),DRAWNULL);
{TD21A:=IF(1,B,DRAWNULL);}
D1:=TD11A AND TD21A;
TD12A:=IF(2,TDP=2,TDP);
TD22A:=IF(2,LLV(C,2)<REF(L,2),DRAWNULL);
{TD22A:=IF(2,B,DRAWNULL);}
D2:=TD12A AND TD22A;
TD13A:=IF(3,TDP=3,TDP);
TD23A:=IF(3,LLV(C,3)<REF(L,2),DRAWNULL);
{TD23A:=IF(3,B,DRAWNULL);}
D3:=TD13A AND TD23A;
TD14A:=IF(4,TDP=4,TDP);
TD24A:=IF(4,LLV(C,4)<REF(L,2),DRAWNULL);
{TD24A:=IF(4,B,DRAWNULL);}
D4:=TD14A AND TD24A;
TD15A:=IF(5,TDP=5,TDP);
TD25A:=IF(5,LLV(C,5)<REF(L,2),DRAWNULL);
{TD25A:=IF(5,B,DRAWNULL);}
D5:=TD15A AND TD25A;
TD16A:=IF(6,TDP=6,TDP);
TD26A:=IF(6,LLV(C,6)<REF(L,2),DRAWNULL);
{TD26A:=IF(6,B,DRAWNULL);}
D6:=TD16A AND TD26A;
TD17A:=IF(7,TDP=7,TDP);
TD27A:=IF(7,LLV(C,7)<REF(L,2),DRAWNULL);
{TD27A:=IF(7,B,DRAWNULL);}
D7:=TD17A AND TD27A;
TD18A:=IF(8,TDP=8,TDP);
TD28A:=IF(8,LLV(C,8)<REF(L,2),DRAWNULL);
{TD28A:=IF(8,B,DRAWNULL);}
D8:=TD18A AND TD28A;
TD19A:=IF(9,TDP=9,TDP);
TD29A:=IF(9,LLV(C,9)<REF(L,2),DRAWNULL);
{TD29A:=IF(9,B,DRAWNULL);}
D9:=TD19A AND TD29A;
TD10A:=IF(10,TDP=10,TDP);
TD20A:=IF(10,LLV(C,10)<REF(L,2),DRAWNULL);
{TD20A:=IF(10,B,DRAWNULL);}
D10:=TD10A AND TD20A;
TD110A:=IF(11,TDP=11,TDP);
TD210A:=IF(11,LLV(C,11)<REF(L,2),DRAWNULL);
{TD210A:=IF(11,B,DRAWNULL);}
D11:=TD110A AND TD210A;
TD120A:=IF(12,TDP=12,TDP);
TD220A:=IF(12,LLV(C,12)<REF(L,2),DRAWNULL);
{TD220A:=IF(12,B,DRAWNULL);}
D12:=TD120A AND TD220A;
TD130A:=IF(13,TDP=13,TDP);
TD230A:=IF(13,LLV(C,13)<REF(L,2),DRAWNULL);
{TD230A:=IF(13,B,DRAWNULL);}
D13:=TD130A AND TD230A;
DRAWTEXT(D1,L-0.6,'1'),COLORRED;
DRAWTEXT(D2,L-0.6,'2'),COLORRED;
DRAWTEXT(D3,L-0.6,'3'),COLORRED;
DRAWTEXT(D4,L-0.6,'4'),COLORRED;
DRAWTEXT(D5,L-0.6,'5'),COLORRED;
DRAWTEXT(D6,L-0.6,'6'),COLORRED;
DRAWTEXT(D7,L-0.6,'7'),COLORRED;
DRAWTEXT(D8,L-0.6,'8'),COLORRED;
DRAWTEXT(D9,L-0.6,'9'),COLORRED;
DRAWTEXT(D10,L-0.6,'10'),COLORRED;
DRAWTEXT(D11,L-0.6,'11'),COLORRED;
DRAWTEXT(D12,L-0.6,'12'),COLORRED;
DRAWTEXT(D13,L-0.6,'13'),COLORRED;
{神奇数列时间循环周期}
{菲波纳契螺旋周期;易学难精;关注成黄金分割比率的波段位置}
DRAWTEXT(CURRBARSCOUNT=3,HIGH*1.02,'3'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=5,HIGH*1.02,'5'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=8,HIGH*1.02,'8'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=13,HIGH*1.02,'13'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=21,HIGH*1.02,'21'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=34,HIGH*1.02,'34'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=55,HIGH*1.02,'55'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=89,HIGH*1.02,'89'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=144,HIGH*1.02,'144'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=233,HIGH*1.02,'233'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=377,HIGH*1.02,'377'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=610,HIGH*1.02,'610'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=987,HIGH*1.02,'987'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1597,HIGH*1.02,'1597'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=2584,HIGH*1.02,'2584'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=4181,HIGH*1.02,'4181'), COLORGREEN;


{股票视频教程网,http://9188edu.net,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!