股票视频教程网

大智慧数据分析源码

Class:大智慧公式 Time:2017-8-21 Hits:632

{计算股价}

input:股数(0,0,10000000),买入价(0,0,500),预期涨幅(0,0,100),服务费(0,0,100){根据各证券所收费不同,自行调节};

预卖价位:=买入价*(预期涨幅*0.01+1);

买入收费:=买入价*股数*0.0018{各证券所收费不同,自行调节}+服务费;

卖出收费:=预卖价位*股数*0.0028{各证券所收费不同,自行调节}+服务费;

预期盈利:=预卖价位*股数-买入价*股数-买入收费-卖出收费;

DRAWTEXTREL(320,850,'¤预卖价位: '+NUMTOSTRN(预卖价位,2)+' 元'),LINETHICK5,COLORAFAFAF;

DRAWTEXTREL(540,850,'¤预期盈利: '+NUMTOSTRN(预期盈利,2)+' 元'),LINETHICK5,COLORAFAFAF;

{庄家实力}

cyc0:=MAXCYC;

庄家实力:c/cyc0,precis2,LINETHICK0,COLORC68CFF;

DRAWTEXTREL(100,70,'☆庄家实力: '+NUMTOSTRN(庄家实力,2)+' 级'),LINETHICK5,COLORC68CFF;

{精确风险系数}

rsv:=(c-llv(l,15))/(hhv(h,15)-llv(l,15))*100;

kk:=sma(rsv,10,1);

dd:=sma(kk,5,1);

zlcm:=intpart(sma(rsv,10,1));

shcm:=intpart(sma(kk,5,1));

风险系数:zlcm+shcm-70,precis0,LINETHICK0,COLOR66FFFF;

DRAWTEXTREL(320,70,'※风险系数: '+NUMTOSTRN(风险系数,2)+' 级'),LINETHICK5,COLOR66FFFF;

{历史价位系数}

历史价位:(c- llv(l,0))/(hhv(h,0)-llv(l,0))*100,precis0,LINETHICK0,COLORFFBB77;

DRAWTEXTREL(755,70,'⊙历史价位: '+NUMTOSTRN(历史价位,2)+' %'),LINETHICK5,COLORFFBB77;

{量能饱和度}

饱和量度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C) /(HHV(AMOUNT,20)/HHV(C,20))*100),precis0,LINETHICK0,COLORE07EAA;

DRAWTEXTREL(60,270,'§饱和量度: '+NUMTOSTRN(饱和量度,2)+' ℃'),LINETHICK5,COLORE07EAA;

{股价倾斜系数}

hot:=ma(c,13);

倾斜系数:atan(hot-ref(hot,1))*3.142*100,precis0,LINETHICK0,COLORFFCC62;

DRAWTEXTREL(245,270,'∥倾斜系数: '+NUMTOSTRN(倾斜系数,2)+' 度'),LINETHICK5,COLORFFCC62;

{获利比例}

获利比例:WINNER(CLOSE)*100,precis0,LINETHICK0,COLOR79A5FF;

浮筹比例: (winner(c*1.1)-winner(c*0.9))/winner(hhv(h,0))*100,precis0,LINETHICK0,COLORFFCC62;

DRAWTEXTREL(430,270,'◇获利比例: '+NUMTOSTRN(获利比例,2)+' %'),LINETHICK5,COLOR79A5FF;

DRAWTEXTREL(615,270,'□浮筹比例: '+NUMTOSTRN(浮筹比例,2)+' %'),LINETHICK5,COLORFFCC62;

{人均持股}

人均持股:=INTPART(FINANCE2(36)/extradata('散户线')*10000);

DRAWTEXTREL(800,270,'〓人均持股: '+NUMTOSTRN(人均持股,0)+' 股'),LINETHICK5,COLOR79A5FF;

{止损价位}

LC:=REF(CLOSE,1);

止损价位:=(LC*1.0035*97+0.2)/99.65;

DRAWTEXTREL(100,850,'☆止损价位: '+NUMTOSTRN(止损价位,2)+' 元'),LINETHICK5,colorWHITE;

{成本预测}

建仓成本:MAXCYC,precis2,LINETHICK0,COLORFFBB77;

心理价位:DMA(AMOUNT/(100*VOL),VOL /(100*FINANCE2(37)))*1.12,precis2,LINETHICK0,COLORC78EFF;

DRAWTEXTREL(60,470,'○建仓成本: '+NUMTOSTRN(建仓成本,2)+' 元'),LINETHICK5,COLORFFBB77;

DRAWTEXTREL(60,660,'◎心理价位: '+NUMTOSTRN(心理价位,2)+' 元'),LINETHICK5,COLORC78EFF;

{上升空间}

上升空间:100-c/(心理价位-建仓成本)*10,precis0,LINETHICK0,COLOR79A5FF;

DRAWTEXTREL(540,70,'‖上升空间: '+NUMTOSTRN(上升空间,2)+' %'),LINETHICK5,COLOR79A5FF;

{股价预测}

VC:=(HIGH+LOW+OPEN+2*CLOSE)/5;

明日阻力:=2*VC-LOW;

明日支撑:=2*VC-HIGH;

明日突破:=VC+(HIGH-LOW);

明日反转:=VC-(HIGH-LOW);

今日阻力:=REF(明日阻力 , 1);

今日支撑:=REF(明日支撑 , 1);

今日突破:=REF(明日突破 , 1);

今日反转:=REF(明日反转 , 1);

DRAWTEXTREL(245,470,'↑今日支撑: '+NUMTOSTRN(今日支撑,2)+' 元'),LINETHICK5,COLOR5959FF;

DRAWTEXTREL(430,470,'↓今日阻力: '+NUMTOSTRN(今日阻力,2)+' 元'),LINETHICK5,COLOR61FE78;

DRAWTEXTREL(615,470,'♂今日突破: '+NUMTOSTRN(今日突破,2)+' 元'),LINETHICK5,COLOR66FFFF;

DRAWTEXTREL(800,470,'♀今日反转: '+NUMTOSTRN(今日反转,2)+' 元'),LINETHICK5,COLORFC878F;

DRAWTEXTREL(245,660,'↑明日支撑: '+NUMTOSTRN(明日支撑,2)+' 元'),LINETHICK5,COLOR5959FF;

DRAWTEXTREL(430,660,'↓明日阻力: '+NUMTOSTRN(明日阻力,2)+' 元'),LINETHICK5,COLOR61FE78;

DRAWTEXTREL(615,660,'♂明日突破: '+NUMTOSTRN(明日突破,2)+' 元'),LINETHICK5,COLOR66FFFF;

DRAWTEXTREL(800,660,'♀明日反转: '+NUMTOSTRN(明日反转,2)+' 元'),LINETHICK5,COLORFC878F;

{实际盈亏}

实际盈亏:c*股数-买入价*股数-买入收费-卖出收费,precis2,LINETHICK0,colorWHITE;

DRAWTEXTREL(755,850,'¥实际盈亏: '+NUMTOSTRN(实际盈亏,2)+' 元'),LINETHICK5,colorWHITE;




 

{股票视频教程网,http://9188edu.net,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!